Use these instructions to download and install the cloudLibrary by bibliotheca App on your Fire.

  1. Mac App For Kindle Fire Not Working
  2. Mac App For Kindle Fire Hd 8 9

IMPORTANT NOTE: Before proceeding with the below listed instructions, you will need to confirm which generation your Fire is. If you need help determining which Fire you have use the information here.

In order to use iCloud mail on a Kindle you must use an app-specific password. In order to create an app-specific password, you must enable two-factor authentication. In order to enable two-factor authentication, you must own a device that's using iOS 9 or OS X El Capitan or later. Watch live TV, access on-demand content, schedule your DVR and more, all from the Optimum App. Download for Windows, Mac, Android, iPhone, iPad, Kindle and more.

The Fire will NOT notify you of system updates. To get the latest version, uninstall and reinstall the App using the provided instructions.

Mac App For Kindle Fire

Fire Installation Video Tutorial, for all our how-to videos click here.

Version 5.0.4.5 was released on October 8th for 4th generation and up Fires. To check your version, tap on About in the cloudLibrary Account menu

Mac App For Kindle Fire Not Working

Go to the settings menu by tapping the settings icon or swiping down from the top of the screen.

Choose Security (on some Fires you will need to choose Device).

Turn on the option allow Apps from Unknown Sources.

Mac App For Kindle Fire

Mac App For Kindle Fire Hd 8 9

You will get a warning message Click Ok.

Go back to the Home screen.

Swipe down from the top of the screen. This pulls up the Quick Settings menu.

Tap More.

Choose Settings then Device (on some Fires you will need to go to Applications).

Tap on the option to turn on Allow Installation of Applications from Unknown Sources.

Go back to the Home screen.

On your Fire Open the Silk browser and navigate to https://www.yourcloudLibrary.com

Scroll down the page and tap on the Fire icon.

Tap on the red download button below that matches your generation of your Fire.

Reader

*If you need help determining which Fire you have use the information here.

*For more information about using audiobooks with 3rd gen fires click here.

Tap Ok to message.

Tap open Download complete.

When asked “Do you want to install this application?” select install and then open.

If the app does not open, tap on the Home icon and tap on the cloudLibrary™ icon to open the app.

cloudLibrary™ app


Select your country and state
from the drop down menus.

Select your library and enter your library card number or ID/PIN.

For additional help and information, visit our FAQ section here.

cloudLibrary is currently not compatible with Kindle Paperwhites or the kindle e-ink device Apps. If you would like to read ebooks on your kindle e-ink device please email [email protected] and request that Amazon allow compatibility with cloudLibrary.